How to fix common library issues

We’ve put together this article to address common library issues and how to fix them. Take a look below but, if the problem persists after trying these solutions, please contact us. Please provide as much detail as possible about the issue.

I copy and paste a Symbol but it’s not linked to the library

If you open a Library file and copy a Symbol instance or source to another Sketch document, it will create a new local Symbol and detach from the Library; this is the expected behavior.

To keep your Symbols linked, add them using the Insert Menu or the Insert Window, which you can open by pressing the letter C on your keyboard. The below image shows the Insert Menu:

Insert menu in the Mac app

The Insert Window option on the menu bar:

Insert Window menu option

How to migrate local Libraries to your Workspace

There’s a quick and straightforward way to migrate your local Libraries (and files if necessary) to your Workspace, keeping all your symbol instances linked. Please follow the instructions detailed in this guide and you’ll have your Workspace Libraries in no time!

Why am I not getting Library updates after saving changes?

If you have a Library installed and are no longer getting updates check the following:

  • Check for starred updates - Any changes made after starring an update will be saved correctly in the Library. Be aware that you won’t get them as an update, even if you are an Editor, unless you eliminate the starred update or star a later version of the library.
  • Check that the file is still shared as a Library - If the file is not saved as a Library, you won’t get any updates. Open the file in your Workspace and check it is shared as a Library in the Settings option

Why are my Symbols not syncing?

If your Symbol instances do not reflect the latest changes made to your Library, try using File > Sync Library Components…

If the problem persists after syncing, check the file in your Workspace to ensure it’s still saved as a Library and has no sharing restrictions.

If you cannot find the file on your Workspace, it might be in a restricted project. A Workspace Admin will need to grant you access to the project so you can continue to receive Library updates.

Why do I see an alert message when syncing library components?

Sketch has a built-in feature to sync symbol instances with their source libraries. You can find this feature in File > Sync Library Components… When you use it, the following alert message is sometimes displayed.

Alert message when using the menu option File > Sync library components

You can safely dismiss the message, and your Symbol instances will be synced most of the time appropriately.

This message displays because Sketch remembers where every Symbol and shared style originated. While working with Libraries, it’s also very common to eliminate styles or libraries we no longer use but Sketch remembers them.

Sketch tries to sync with the source of every Symbol and style and alerts you if it can’t find something, and this is why the message is displayed.

Was this article useful?

Thanks for your feedback.
An error occurred, please try again later.

Can’t find your answer?

Contact us and we’ll get back to you as soon as we can.

Documentation

Documentation

Learn more about how to use the powerful features that Sketch gives you in our documentation.

Manage your Workspace

Manage your Workspace

View your Workspace details, manage your members and more in your Workspace settings.

Subscriptions

Subscriptions

Subscriptions are the primary way to use Sketch and we've made switching easy.

Legacy licenses

Legacy licenses

Manage, renew or recover legacy Mac-only (SK3) license keys.