Skip Navigation

Templates

Using Templates

You can open templates template as a new document with pre-populated layers. The Mac app comes with several useful sample templates, including the iOS App Icon and Material Design templates.

You’ll see a grid view of templates in the Workspace window. You can bring this up at any time by choosing Window > Workspace.

A screenshot showing the templates browser in the workspace window in Sketch

You can also get a list of templates by choosing File > New From Template….

Creating Templates

To save a document you’ve created as a template, choose File > Save as Template….

Templates are local documents only, and you can find them in ~/Library/Application Support/com.bohemiancoding.sketch3/Templates. This is also where you can save a custom preview image to appear in the Workspace window.

How to Create Custom Template Previews

To give your templates a custom preview, add a PNG image with the same filename as your template to its location in the Finder. For pixel-perfect previews, images should be 188 × 188 px for Retina displays, or 94 × 94 px otherwise.

Last updated on 08 Jun 2022

Was this article useful?

Thanks for your feedback.
An error occurred, please try again later.