Shortcuts

Keyboard shortcuts are the fastest way to speed up your workflow. Many of them are depend on what you’ve selected and what you’re doing, but you’ll find the full list of Sketch Keyboard shortcuts below.

General shortcuts

+ C Copy
+ X Cut
+ V Paste
+ + V Paste over selection
 Space  + drag Pan Canvas
+ + N New page
fn + Previous page
fn + Next page
+ + Zoom in
+ - Zoom out
Ctrl + R Show/hide rulers
Ctrl + P Show/hide pixels
Ctrl + X Show/hide pixel grid
Ctrl + G Show/hide grid
Ctrl + L Show/hide layout
Ctrl + E Show/hide slices
Ctrl + F Show/hide prototyping
+ F Filter in Layer List
+ Ctrl + K Run custom plugin
+ Z Undo
+ + Z Redo
N New document*
N New Cloud document*
O Open document*
O Open Cloud document*
+ W Close window
+ S Save document
+ + S Duplicate document
+ + + S Save document as…
+ + P Page setup
+ , Open Preferences
+ H Hide Sketch
+ Q Quit Sketch
+ + ? Open the Help menu
+ P Open the Prototyping Preview window

*These shortcuts work in reverse if you’ve enabled document saving to Sketch Cloud by default.

Inserting Layers

You can use the following shortcuts instead of choosing them in the Insert menu.

R Rectangle
O Oval
L Line
U Rounded rectangle
V Vector tool
P Pencil tool
T Text tool
A Artboard tool
S Slice tool
H Hotspot tool
-drag Draw a new shape from center
-drag Lock the ratio of shape as you draw it
 Space -drag Move a new layer before you place it

Selecting Layers

Click Select a layer
Click-and-drag Select multiple layers
-drag Only select layers within your drag selection
Double-click Select a layer with a group
-click Select a layer within a group
-click Select an obscured layer
+ A Select all layers
+ + A Select all Artboards
-click Add layer to/remove layer from your selection
+ -click Add layer from a group to your selection
-click Add layer to selection/deselect layer in Layer List
-click Select a range of layers in Layer List
fn + Select next Artboard
fn + Select previous Artboard
+ + J Reveal selection in Layer List

Moving and Resizing Layers

As you move or resize layers, you’ll see smart guides and measurements automatically.

-hover Display distance between other layers
+ D Duplicate
-drag Duplicate
-drag Move layer along X or Y axis
-drag Move layer and ignore smart guides
+ -drag Move an obscured layer
Arrow keys Nudge layer any direction by 1 px*
-Arrow keys Nudge layer any direction by 10 px*
+ K Scale layer
and resize Resize layer from center
and resize Preserve the layer’s ratio
+ or Expand by 1 px
+ or Contract by 1 px
+ + or Expand by 10 px
+ + or Contract by 10 px
Ctrl + -hover Show distance to baseline/cap height on text layers

*You change this value in Preferences.

Editing Layers

When you’ve selected a layer, you can use the following shortcuts:

Enter Edit layer
Escape Finish editing
+ Tab Edit the X position in the Inspector
Delete layer
+ + C Copy style
+ + V Paste style
Ctrl + S Sync shared style
Ctrl + + S Reset shared style
W Add link to Artboard
F Toggle fill
B Toggle border
Ctrl + C Pick color
0 to 9 Edit layer opacity
+ + T Transform shape
+ + R Rotate layer
+ Ctrl + M Use the layer as a mask
+ Escape Return to instance
+ + U Union multiple layers
+ + S Subtract multiple layers
+ + I Intersect multiple layers
+ + X Difference multiple layers

Vector Editing

+ + O Open/close path
Tab Select the next point
Show all handle control points
1 Straight point type
2 Mirrored point type
3 Disconnected point type
4 Asymmetric point type
Double-click vector point Toggle point between Straight and Mirrored
-drag vector point Move point along X or Y axis
-drag handle control point Convert your selected point to a Disconnected type
-click (when inserting points) Place new point at a 45º angle
-click path segment Place new point between existing points
-click path segment Curve the path between existing points

Text Editing

+ + + V Paste as rich text
+ T Change typeface
+ B Bold
+ I Italic
+ U Underline
+ + + Increase font size
+ + - Decrease font size
Ctrl + + L Increase character spacing
Ctrl + + T Decrease character spacing
+ + { Align left
+ + | Align center
+ + } Align right
+ +  Space  Emoji & symbols
+ + O Convert to outlines
+ Return Insert a line break

Organizing Layers

Use these shortcuts to organize your layers.

+ G Group
+ + G Ungroup
+ R Rename layer
Tab Select next layer in group
+ Tab Select previous layer in group
Enter Selects layer inside group
Escape Selects parent group
Click-and-drag layer Adjust layer hierarchy
+ ] Bring forward
+ + ] Bring to front
+ [ Send backward
+ + [ Send to back
+ + + Move up (out of group/Artboard)
+ Ctrl + H Distribute horizontally
+ Ctrl + V Distribute vertically
-click Align buttons Align layer to Artboard
+ + H Hide/show layer
+ + L Lock/unlock layer

Exporting Layers

+ + E Export
+ E Export selected layer(s)
Drag a layer/thumbnail to Desktop Export asset
Drag a layer/thumbnail to Canvas Insert flattened duplicate
/ in layer name Includes folder in export

Zoom and Focus

+ 0 Zoom to 100%
+ 1 Zoom to all elements on Canvas
+ 2 Zoom to selected layer(s)
+ 3 Center selected layer(s) in the Canvas
Z-drag Zoom to area
Z-click Zoom in
+ Z-click Zoom out
~ (§ on some keyboards) Temporarily zoom out to 100%
+ Ctrl + F Toggle full screen
+ + 1 Show/hide Layer List
+ + 2 Show/hide Inspector
+ . Enter presentation mode
+ + T Show/hide Toolbar

Text Fields

These shortcuts apply when you’re editing a numerical field in the Inspector:

+ Tab Focus Inspector
Tab Select next field
+ Tab Select previous field
Enter Confirm change
Escape Clear change
Increase value by 1
Decrease value by 1
+ Increase value by 10
+ Decrease value by 10
+ Increase value by 0.1
+ Decrease value by 0.1
click and drag label Adjust value in increments of 10
click and drag label Adjust value in increments of 0.1

Resizing Shortcuts

When you’re adjusting the height or width of a layer, the following characters give you more control over the starting position of the resize.

L Scale from the left (default)
R Scale from the right
T Scale from the top (default)
B Scale from the bottom
C / M Scale from the center / middle

How to Use Math Operators

You use these math operators in all numerical inputs of the Inspector.

+ Add
- Subtract
* Multiply
/ Divide
% Resize layer to a percentage of its parent group or Artboard

How to Set Individual Radius Values

When you select a rectangle, you can specify a different value in the radius field for each corner in the Inspector by using ; as a spacer (e.g. 40;0;40;0).

Export Fields Shorthand

In the Scale field of the Make Exportable panel in the inspector, the following characters can customize your export sizes.

X Scale multiplier. Eg, 2x will export at twice the size
H Export your layer at a specific height. Eg, 512h
W Export your layer at a specific width. Eg, 512w

Miscellaneous

These shortcuts are available for specific tools or when you’re performing specific actions.

on startup Launch Sketch with all plugins disabled
+ Ctrl + D Detach from Symbol
+ Ctrl + + D Detach all contents from Symbol
+ + D Refresh Data
+ Ctrl + R Run the last plugin you used again
-drag selection handle Rotate layer
-drag when rotating Snap rotation to 15º increments
0-9 With a gradient stop selected, position it between 0% and 100%
= Position selected gradient stop directly between two existing stops

Custom Shortcuts

You can create custom shortcuts for Sketch by opening System Preferences, heading to Keyboard › Shortcuts › App Shortcuts and clicking the add button. In the pop-up menu, select Sketch under the Application drop-down menu and set up your custom shortcut.

Last modified on Aug 09, 2019

Was this article useful?

Yes
No

We’re really sorry about that.
Please let us know what you were looking for:

If you need more help or you’d like to report a bug with this content, please contact support.

Thanks for your feedback.
An error occurred, please try again later.

Start working faster today

Available exclusively on the Mac for just $99.