Skip Navigation

Layer Styles

Layer Styles work in exactly the same way as Text Styles. The only difference is that they work with shape layers, while Text Styles work with text layers.

How to create a Text or Layer style

To create a Layer Style, select a shape Layer that you’ve applied styles to, then choose Layer > Create new Layer Style from the menu. Alternatively, open the Components View, click on the Layer Styles Layer Styles tab on the toolbar and then on the Create tab. Editing and applying Layer Styles follows the exact same process as Text Styles.

Tip: You can include Layer Styles a part of a Library for sharing with others. Take a look at Library Styles for more details.

How to insert a Text or Layer style as a new layer

Inserting a Text or Layer style as a new layer via the Insert Window

You can insert a Text or Layer Style as a new layer using the Insert Window. Press C to open the Insert window or choose Window > Insert in the Insert menu Insert. Select the Layer or Text Styles tab. Then, choose or search for the style you are looking for. Drag and drop onto the Canvas to create a new layer.

Inserting a Text or Layer Style as a new layer via the Components View

To insert a Layer Style or Text Style from the Components View, select the component you want to insert as a new layer and click on Insert Shape with Style or Insert Text with Styles in the Inspector.

You can also choose Insert in the toolbar and select the Text Style or Layer Style you want to use. Then click anywhere on your Canvas to insert the new text or shape layer.

How to override a Layer Style

There are two ways to override a Layer Style within a Symbol:

  • Swap the Style for another one, for either the whole Symbol instance or for a specific layer within it.
  • Override Style attributes on the layer within the Symbol instance.

Note: Changing Styles won’t affect your existing individual overrides.

You can limit what people can override in your Layer Styles by navigating to the Symbol Source and using the Manage Overrides options in the Inspector.

How to delete a Layer Style

To delete a Layer Style, switch to the Components View in the Mac app. Head to View > Components in the menu bar, or use the keyboard shortcut ctrl2. Then, click on the Layer Styles Layer Styles tab. Select the style you want to delete and press the backspace key.

Last updated on 25 Oct 2022

Was this article useful?

Thanks for your feedback.
An error occurred, please try again later.