Preferences

Press + , from anywhere in Sketch, or choose Sketch > Preferences to bring up the preferences window.

Inside, you’ll find eight tabs:

General

An annotated image showing the General tab in Preferences
  1. Appearance gives you the option of a light or dark UI for Sketch, regardless of your system settings (macOS Mojave 10.14 or later).
  2. Canvas gives you the option of a light or dark canvas, regardless of your Appearance setting.
  3. New Documents gives you the option to save new documents you create locally or on Sketch Cloud.
  4. Auto Save saves local documents so you can access and revert to previous saves using the macOS Versions feature. Cloud documents are automatically and regularly saved locally.
  5. Privacy lets you opt in to share completely anonymous diagnostics and usage data that cannot be used to identify you.

Canvas

An annotated image showing the Canvas tab in Preferences
  1. Color Profile gives you different color profile options for Sketch to render your documents with.
  2. Animate Zoom applies a transition to help you see where you’ve come from when you’ve zoomed into a specific part of your document.
  3. Zoom In On Selection will focus on your current selection when you zoom in, rather than zooming towards the center of the canvas.
  4. Zoom Back to Previous Canvas Position zooms out to your position on the canvas before you zoomed in, instead of zooming out from the center.
  5. Nudging lets you set the distance you’ll move layers by nudging them with the arrow keys, as well as how that distance changes when you hold down shift.
  6. Colors lets you customize how any guides look, as well as any prototyping overlays.

Layers

An annotated image showing the Layers tab in Preferences
  1. Pixel Fitting will round layers to nearest whole pixel and makes sure they don’t sit on fractional pixels when you draw, move or resize them.
  2. New Groups gives you the option to select layers within any new group you create without having to hold or open the group first.
  3. Bitmap Import gives you the option to scale down images to fit inside Artboards, or have them overflow at full size.
  4. Vector Import attempts to interpret the path data inside PDF and EPS files you import and make it editable, rather than importing them as flat images.
  5. Artboard Exports gives you choose how artboards are ordered when you export them as a PDF.
  6. Editing Shapes lets you choose whether not to close the path by clicking on the first, or last, end point when editing an open path.
  7. Offset Duplicated Layers will offset any layer duplicate by 10px from the original.
  8. Rename Duplicated Layers will add ‘copy’ to the end of a duplicate layer’s name to make sure it’s unique.
  9. Flatten Bitmaps lets you choose what resolution you would like bitmap images to be flattened to when using the Layer > Flatten Selection to Bitmap command.

Plugins

An annotated image showing the Plugins tab in Preferences
  1. Quickly disable plugins without uninstalling them, by toggling their checkboxes.
  2. Control-clicking on an individual plugin will bring up options to disable it, uninstall it, or show it in Finder.
  3. The cog menu gives you options to disable plugins and bring up the plugins folder in Finder.
  4. Get Plugins takes you to the plugins directory on sketch.com.

Data

An annotated image showing the Data tab in Preferences
  1. Toggle visbility of your data sources using the checkboxes, this is handy when you have lots of data sources to manage.
  2. Control-clicking on a data source will bring up options to show it in the Finder, remove it altogether or show any connected data plugins (not available for built-in plugins).
  3. The cog menu gives you the same options for any data source you’ve selected as if you have control-clicked on it.
  4. Add data lets you add data sources from anywhere on your computer via the standard macOS open dialog. You can also drag data sources straight into the Preferences window.

How to Create Data Sources

For information how to create data sources, take a look at the data section.

Libraries

To add a new Library, choose Add Library… in the Preference tab and select the .sketch Library document.

An annotated image showing the different parts of the Sketch interface.
  1. Team Libraries, Remote Libraries and Local Libraries will be displayed in separate sections.
  2. Toggle visbility of your Libraries in Sketch using the checkboxes, this is handy when you have lots of Libraries to manage.
  3. Control-clicking on a Library in the list will bring up options to show it in the Finder, open it, View it in Sketch Cloud or remove it altogether.
  4. The cog menu gives you the same options for any Library you’ve selected as if you have control-clicked on it.
  5. Add Library lets you add Libraries from anywhere on your computer via the standard macOS open dialog.

Note: Removing a Library that any of your Sketch documents are using will unlink any symbols in that document and move them into the local Symbols page. This is destructive and you can’t undo this process.

How to Restore Missing Libraries

If you see a warning in your Library preferences about a missing Library, this means Sketch can’t find that .sketch Library document.

If you know you still have the document, Control-click the Library, or click the cog icon at the bottom of the list with the Library selected, choose Locate…, and select the library again.

How to Add Custom Library Thumbnails

If you want to create a custom preview for your Library, somewhere in the document, create a new 1:1 (square) Artboard and give it the name, “Library Preview”.

Presets

In the Export Presets Preference tab, you’ll find a list of all your presets that you can use when making a layer, slice, or Artboard exportable:

An annotated image showing the Export Presets tab in Preferences
  1. The radio button sets the default preset.
  2. The add button adds a new preset to the list.
  3. The remove button will remove any preset you’ve selected.
  4. The name field lets you name the preset set.
  5. The preset fields work the same as the ones you’ll find in the Make Exportable panel in the Inspector.

Account

In the Cloud Preference tab, you can log in and out of your Sketch Cloud and view your account details. For more information about Sketch Cloud, take a look at the Cloud section.

Last modified on Oct 23, 2019

Was this article useful?

Yes
No

We’re really sorry about that.
Please let us know what you were looking for:

If you need more help or you’d like to report a bug with this content, please contact support.

Thanks for your feedback.
An error occurred, please try again later.

Start working faster today

Available exclusively on the Mac for just $99.