Styling

When you select a layer in Sketch, you’ll can create and edit its style properties in the Inspector.

Fills

Sketch support five different fill types:

  • Solid Fill
  • Linear Gradient
  • Radial Gradient
  • Angular Gradient
  • Image Fill

By default, all new layers have a single, solid color fill.

How to Add a New Fill

To add a new fill, click the + icon in the Fills panel. You can create add as many fills as you like to a single layer and they’ll stack on top of each other. For each fill you create, you’ll have the following options:

An annotated image showing the different fill options and controls
  1. Enable/Disable checkbox
  2. Colour/Preview well. Click on this to select a different color or change the fill type. Read more about colours.
  3. Blending Mode. Click the icon and select a blending mode. If you select anything other than Normal, the icon’s color will change to blue.
  4. Fill Options. If you’re using a solid color fill, you’ll see that color’s HEX value here for easy copy and pasting. If you’re using a graident or image fill, you’ll see options to change their type here.
  5. Opacity. Along with blending modes, you can change a fill’s opacity to combine and show two or more fill types.

Tip: Press f to toggle the visibility of all fills for any selected layer.

How to add an Image Fill

Click on the the color well on a fill’s options and then click the image fill button on the right in the popover. Select your own image by choosing Choose Image…, pick one from the presets at the bottom of the popover, or click the Data icon to select one from a data source.

You can then choose from four different fill types:

  • Fill adjusts the size of the image to fit the layer’s width.
  • Fit adjusts the size of the image to fit the layer’s height.
  • Stretch fits the image to the layer’s height and width ratio by stretching it.
  • Tile keeps the image at its original size, with the option to adjust this, and tiles it to fit the layer.

You can also slick the clock icon above the image preview to see frequently used images in your document, or choose a basic pattern or noise fills from the global presets at the bottom.

How to Change Fill Settings for Overlapping Paths

When you’ve applied a fill to a shape, click on the settings icon near the Fills section title. From here you can choose whether to use the Non-Zero or Even-Odd rules to fill shapes, according to the winding rule.

The Color Popover

Click the color well for any fill, border or shadow to reveal the color picker popover.

An annotated image showing the different color popover controls
  1. The fill icons across the top switch between solid, gradient and image fills and change the color popover’s settings to match.
  2. The color picker uses the HSB (hue, saturation, brightness) color model. Drag the point left to right to change a color’s saturation, and up or down to change its brightness.
  3. The sliders control your color’s hue (color) and alpha (opacity).
  4. The preview shows the final result of your color settings.
  5. The eyedropper lets you pick any color from your display, inside or outside of Sketch. You can quickly access it by selecting a layer and pressing Ctrl + C.
  6. The text fields give you quick access to your color’s HEX value for copying and pasting, and the option to manually set a specific color using RGB (red, green, blue) and alpha values. You can click on the RGB labels to switch to HSB (hue, saturation, brightness) or HSL (hue, saturation, lightness).
  7. The clock icon gives you a list of frequently used colors in your document so you can quickly select a color you’re already using.
  8. The collapse arrow toggles hiding and showing the color picker so you can give more room to color presets (if you’re using them).

How to Find and Replace a Specific Color

Choose Edit > Find and Replace Color… from the menu (or press + + F to bring up the Find and Replace Color menu. From there, select the color you want to find within your design and the color you want to replace it with.

An image showing the Find and Replace Color sheet in Sketch

Enable “Include all opacities of this color” to find all colors with different alphas, but the same RGB or HEX values.

Enable “Preserve original opacity” to keep those different alphas intact when you replace the color.

Presets

At the bottom of the color popover, you can store color, gradient or image fill presets for quick access and reuse within your document or as part of a library.

How to Add a Preset

To add a preset, select your color, gradient or image fill, choose whether you’d like to add it to your global (all documents) or document (this document only) presets, then click the + icon.

To rename your preset, make sure you’re viewing your presets in list view, control-click on it and choose Rename. You can also control-click and choose to move or copy your preset between the global or document locations.

You can drag presets to reorder them, or drag them completely out of the color popover to delete them (or control-click on them and choose Delete).

Finally, when you control-click a solid color preset, you can choose to copy its HEX, RGB, HSL, Objective-C or Swift code color values to the clipboard.

How to create Library Presets

When you save a document preset and make that document a Library, it’ll appear below the Global and Document items in the presets menu to anyone who’s added the Library.

Any presets that have been updated in a Library you’ve added will show a small dot to indicate when they’ve been updated.

Gradients

To apply a gradient fill to a layer, click the color button under the Fills section of the Inspector, then choose either the linear, radial or angular gradient buttons at the top of the popover.

How to Create Linear Gradients

With a linear gradient, Sketch adds a line with two points to your layer.

To change a color on your gradient, click on either point and select a color using the color popover in the inspector. To add another color to your gradient, click anywhere on the gradient line to add a new point.

Drag the color points to change the look of your gradient. Or select a point and press backspace to delete it.

How to Create Radial Gradients

Editing radial gradients is similar to editing linear gradients except that one of the points now sets the middle of the effect and its opposite point sets where the effect ends. By dragging the non-color point, you can control the size of the effect.

How to Create Angular Gradients

Angular Gradients place any color points you create on a circle (based on the maximum height or width of a layer). You can drag the points to adjust their position or click on the circle to add new points.

How to Use the Gradient Bar

Along with the gradient points on your layers, you can use the gradient bar in the color popover to adjust and control your gradient. It works in exactly the same way. Click a point to change its color and drag it to move it, click anywhere on the bar to add a new color, or select a point and press backspace to remove it.

How to Adjust Gradient Points with Shortcuts

You can use the following shortcuts to adjust your gradient:

1 - 9 Position a new color point along the gradient bar (e.g. 3 = 30% along.
= Positions a gradient point equally between two other points.
Tab Switch between color point.
or Adjust the color point position incremenetally.
+ or Adjust the color point position in larger increments.

Borders

You can add as many borders as you like to your layers, with different thicknesses, colors and blend modes. The only layers that can’t have borders are text layers.

Borders can be a solid color, or have a linear, radial or angular gradient fill.

Tip: You can quickly show or hide borders on any layer by pressing B.

How to Set a Border Position

For closed shapes, you can place borders on the inside, outside or center of its outline. For open paths, the only option is center.

An image showing the different border options in the Inspector in Sketch

Border options (left to right): Inside, Center, Outside.

How to Customize Borders

Click the settings icon next to the Borders title to bring up options for caps, ends, arrows and dashed borders:

An annotated image showing the different border options
  1. For line layers and open paths, you can choose from three types of border end: Butt cap (Draws the border right to the vector point), Round cap: (Creates a rounded, semi-circular end to a path that extends past the vector point) or Projecting cap (Similar to the rounded cap, but with a straight edges).

  2. For open and closed paths with three or more points (creating corners) you can choose from three types of join: Miter join: (Creates an angled join), Round join: (Creates a rounded corner for the border with a radius relative to the border thickness) or Bevel join (Creates a chamfered edge on the border corner).

  3. For line layers, you can choose arrowheads for the start and end of the path using the drop-down menus. To switch which ends they appear on, choose Layer > Path > Reverse Order.

  4. To create dashed lines, enter a value in the Dash field to set the length of the dashes. The Gap field, which sets the distance between dashes will automatically match this unless you set it to something different. To reset the the Gap value and have it match again, delete anything in that field.

Tip: To create a dotted line, set the end type to a round cap, then set the dash value to 0. Adjusting the gap distance will change the look of your dotted border.

Shadows

Shadows and Inner Shadows have the same controls but work in different ways. Shadows render outside a layer, while Inner Shadows render inside a layer.

You can apply multiple shadows to the same layer, and control their colors, blending modes, X and Y positions, blur radius and spread.

Note: When you zoom out about 400%, shadows with a blur value will not show on the Canvas. This is to make sure documents using lots of shadows render quickly. This won’t affect any assets you export.

Blurs

To add a blur to your layer, click the Blurs title in the Inspector and then choose a blur type from the drop-down menu:

Guassian Blur applies a blur in all directions. You can set the blur amount using its slider.

Motion Blur blurs in one direction to imply motion. You can set both the blur amount and the angle using the sliders.

Zoom Blur will blur from one point outwards. You can set both the blur amount and the point where it starts from.

Background Blur replicates the blurs behind overlays and panes in macOS and iOS. Content underneath your layer will blur and you can set that content’s saturation and a blur amount in the Inspector. If you have any fill styles on this layer, they’ll need to be transparent in order to see this blur. A transparent color fill is also a great way to tint it.

Note: Applying lots of blurs (or large blurs) can cause Sketch to slow down as they require lots of memory and processing power to render them.

Text Styles

With Text Styles, you can store a set of styles and reuse them across different text layers within your designs. When you make changes to a layer that you’ve applied a Text Style to, you can choose to update the Text Style itself so that all text layers with that Text Styles change as well.

How to Create a Text Style

Select a text layer that you’ve applied styles to, then choose Layer > Create new Text Style from the menu. You can also click the Create button under the pop-up menu that reads No Text Style in the Appearance panel in the Inspector. Type in a name for your new Text Style and press enter to save it.

How to Apply a Text Style

Select a layer and choose the pop-up menu that reads No Text Style under the Appearance panel in the Inspector, then in the Components Popover, select the Text Style you want to apply. You can use search bar at the top of the popover to help you find the style you need.

How to Edit a Text Style

Select a Layer and make sure you’ve applied the Text Style you want to edit, then make your changes to its styles. Once you’ve done this, you’ll see an asterisk (*) appear next to the Text Style’s name. From here, you can click on one of the following buttons in the Appearance panel:

  • Update will apply your changes to this layer and to any other layers using the same style.
  • Create will create a new Text Style with your changes applied to it.
  • Detach will keep the changes you’ve made to that layer but remove the Text Style.
  • More (…) will give you the option to reset a style (if you’ve made a change) or rename it.

Tip: You can include Text Styles a part of a Library for sharing with others. Take a look at Library Styles for more details.

Layer Styles

Layer Styles work in exactly the same way as Layer Styles. The only difference is that they work with shape layers, while Text Styles work with text layers. To create a Layer Style, select a shape Layer that you’ve applied styles to, then choose Layer > Create new Layer Style from the menu. Editing and applying Layers Styles follows the exact same process as Text Styles.

Tip: You can include Layer Styles a part of a Library for sharing with others. Take a look at Library Styles for more details.

How to Insert a Style as a New Layer

You can drag Text and Layer Styles from the Components Panel directly onto the Canvas. This creates a new text or shape layer with the style already applied.

You can also choose Insert in the toolbar and select the Text Style you want to use. Then click anywhere on your Canvas to insert the new text or shape layer.

Organizing Styles

How to Create Style Groups

To group styles together in the Components Panel and Insert menu, name them using the format: Group-name/Style-name. For example, two Symbols named Background/Light and Background/Dark will be places in a group called Background.

Note: For Sketch 60 and earlier, you need to have two or more styles in a group before they’ll appear in their own submenu.

Organizing Styles in the Components Panel

You can organize your Text and Layer Styles in the Components Panel. Double click on a style or group to rename it. You can also drag and drop styles into an existing group or create a new group by simply dragging one style on top of another.

Styles are ordered alphabetically in the Components Panel.

Tips and Tricks

How to Adjust a Layer’s Opactiy

As well as dragging the opacity slider, or typing a percentage in the field next to it, you can quickly set a layer’s opacity, by selecting your layer and pressing 0-9 (e.g. 3 for 30% opacity). Pressing two numbers quickly will set a more exact opacity (e.g. 2 and 5 for 25% opacity).

Pressing single digits reduces this layers opacity to 90, 80 and 70%, then pressing 7 and 5 quickly changes it to 75%.

How to Organize Style Properties

Click on the drag on the space between a style property’s controls to move it above and below other properties.

Check or uncheck the checkbox next to each style property to enable or disable it. If you make an adjustment to a disabled style property, this will enable it.

To remove a style property altogether, click and drag it out of the insepector, control-click on it and choose Remove, or click on the trash icon at the top of the panel (if it’s disabled).

How to Copy and Paste Styles

Select the layer you want to copy styles from, then choose Edit > Copy > Copy Style (or press + + C). Then select the layer you want to paste those styles to and choose Edit > Paste > Paste Style (or press + + V).

Last modified on Oct 23, 2019

Was this article useful?

Yes
No

We’re really sorry about that.
Please let us know what you were looking for:

If you need more help or you’d like to report a bug with this content, please contact support.

Thanks for your feedback.
An error occurred, please try again later.

Start working faster today

Available exclusively on the Mac for just $99.