The Interface

An annotated image showing the different parts of the Sketch interface.
  1. The Canvas. The Canvas is where you create your designs. It’s infinite, so you can set things up however you like and work directly on the Canvas itself without worrying about running out of space. If you’d prefer to work within a fixed frame, you can add Artboards to your Canvas. Read More →

  2. The Toolbar. The Toolbar provides quick and easy access to important tools and actions you’ll use a lot in Sketch. It comes with a handy set of defaults but you customize it with different buttons to suit your needs. To do so, control-click on it and choose Customize Toolbar… or choose View > Customize Toolbar…. Read More →

  3. The Inspector. In the Inspector, you’ll find settings for any layers you’ve selected, or controls for the tool or feature you’re using. Read More →

  4. The Layer List. In the Layer List, you can see and select from all of the pages in your document, and see the artboards and layers on each page. Read More →

  5. The Components Panel. In the Components Panel you’ll find all the Symbols, Text Styles and Layer Styles in your document, as well as any Libraries you have enabled. You can drag components directly from the Components Panel onto the Canvas. Read More →

Tip: To hide the Sketch UI, and view just your work on the canvas, choose View > Hide Interface in the menu (or press + .) to toggle Presentation Mode.

The Canvas

How to Zoom and Navigate the Canvas

You can hold the spacebar and click and drag to pan around the canvas, or use the arrow keys if you haven’t selected any layers.

To zoom in and out, you can hold the key and use your mouse’s scroll wheel, use the pinch gesture on a trackpad or use the buttons in the Toolbar. You can also use the Zoom tool by pressing Z and either clicking to zoom in or holding and clicking to zoom out. With the Zoom tool enabled, you can click and drag a selection to zoom into a specific area.

There are also a few Zoom shortcuts:

+ + Zoom In
+ - Zoom Out
+ 0 Zoom to 100%
+ 1 Zoom to see the whole canvas
+ 2 Zoom to selected layer(s)
+ 3 Center selected layer(s) on the canvas

How to Show Pixels on the Canvas

By default, you’ll view Sketch’s canvas in vector mode. It’s resolution independent and you can zoom infinitely to work at any level of detail.

If you’re working on a design where it’s important to be able to see individual pixels, select View > Canvas > Show Pixels on Zoom or press Ctrl + P to enable Pixel Zoom and view individual pixels when you zoom in past 100%.

Vector and pixel modes

How to Show the Pixel Grid

Select View > Canvas > Show Pixel Grid on Zoom, or press Ctrl + X, to see any edges of your layers that don’t align with the Pixel Grid once you zoom in past 600%.

How to use Rulers and Create Guides

Sketch hides rulers by default, but you can show them by selecting View > Canvas > Show Rulers or pressing Ctrl + R.

You can click and drag on your rulers to set their zero origin anywhere you like on the canvas. To lock them in place, click the lock icon in the corner. To reset your rulers’ origins, choose View > Canvas > Reset Ruler Origin

Clicking the lock icon will stop any accidental ruler movements.

You can click anywhere on a ruler to create a guide. Guides will be visible when your rulers are and if you move a layer on your Canvas it will snap to the nearest guide.

You can move a guide by clicking and dragging on it inside a ruler. To remove it completely, drag it right towards the Layer List or Inspector until your cursor changes. You’ll see that the guide disappears.

To move multiple guides at the same time, click and drag the ruler they’re on. To remove them altogether Control-Click one of the rulers and select Remove All Vertical Guides or Remove All Horizontal Guides, respectively.

How to Create Grids

Sketch supports two types of grid; a regular (square grid) and a layout grid. You can view both at the same time if you need to.

To set up a square grid, choose View > Canvas > Show Grid or press Ctrl + G. To change its settings (the size of the cells, how often thicker lines appear and the color of the lines), choose View > Canvas > Grid Settings….

To set up a layout grid, choose View > Canvas > Layout Settings… and use the options that appear to choose the number of columns and rows, their widths, gutter widths and colors.

You can only apply grids to Artboards, or to the Canvas if there aren’t any Artboards on it. You can edit the layout options for multiple Artboards at the same time.

When you have a layout grid set up, layers will snap to it and ignore Sketch’s Smart Guides.

Measuring

To measure the distance between different layers on the canvas, select the first layer, then hold and hover over the layer you want to measure against. To measure against a layer that’s inside a group, you’ll need to as well.

If you’re measuring the distance to a text layer, holding will measure to the text’s bounding box. Holding Ctrl will measure to the text’s baseline (from the bottom) or cap height (from the top).

You can change the colours of Sketch’s measuring guides via the Canvas tab in Preferences.

How Snapping and Smart Guides work

As you move or insert layers and Symbols on the canvas, Sketch will automatically show you measurements against nearby layers, as well as Smart Guides that help you snap to a nearby layer’s centre or edges.

If you have two or more layers next to each other, and move another near to them, Sketch will highlight their distance and automatically snap that layer to distribute them all equally.

When you resize a layer, if there are similar layers nearby Sketch will show you if they have a similar width or height. This also works when you’re resizing a layer that’s overlapping another.

Finally, when you insert or move text layers, they’ll snap to the height or width of nearby layers. Adjust the height of a text layer will also snap the bounding box to the last line of text.

The Toolbar

The Toolbar is where you’ll find quick shortcuts to important tools and actions you’ll use a lot in Sketch. You can customize the toolbar with different buttons to suit your needs. Simply control-click on it and choose Customize Toolbar… or choose View > Customize Toolbar…. Here’s a rundown of the default toolbar:

An annotated image showing the default toolbar options in Sketch.
  1. Insert gives you quick access to the different layers you can add to the Canvas.
  2. Data inserts text, image or custom data sources into your work. Find out more about Data.
  3. Create Symbol converts a group or layer you’ve selected into a reusable Symbol. You’ll be able to choose a name and Layout options when you create a Symbol. Find out more about Symbols.
  4. Forward, Backward, Group and Ungroup help you organise your layers and move them within the Layer List.
  5. Edit, Rotate, Mask, Scale and Flatten give you quick access to common actions for editing layers.
  6. Union, Subtract, Intersect, and Difference give you quick access to Sketch’s four boolean operations.
  7. Zoom and View change how your designs appear on the Canvas and what you’re focused on.
  8. Preview shows your design or prototype in the Preview window. Find out more about Previewing.
  9. Cloud lets you share your document on Sketch Cloud. Find out more about Sketch Cloud.
  10. Export gives you a quick way to export your document’s assets. Find out more about Exporting.

You can also toggle between hiding and showing the toolbar by pressing T or by choosing View > Show/Hide Toolbar in the Menu Bar.

The Inspector

In the Inspector, you’ll find settings for any layers you’ve selected, or controls for the tool you’re using. The Inspector hides and shows these controls and settings based on what you have selected or what you’re doing.

An annotated image showing the different parts of the Inspector.
  1. Alignment Options. These become active when you select two or more layers. Read more about aligning layers.
  2. Layer Proprties. These let you change the position, size and rotation of layers, as well as flip them.
  3. Text Fields. You can change values in text fields in the Inspector in a few ways. Hovering over them will show up and down arrows to change a value. You can also click and drag left and right on the labels by each field to change their values. Holding while clicking will change it by ten times as much, and will change it by a tenth.
  4. Resizing Constraints. You’ll see these controls if you’ve selected a layer within a group or Artboard. Read more about Resizing Constraints.
  5. Styling. The Styling tools let you control how your layers look. To add a new Style, click the add button next to the section title for the style you want to use. When you’ve added styles, you can hide them by deselecting the checkbox next to them. To remove a style altogether, deselect its checkbox and click the trash icon that appears. Read more about styling.
  6. Exporting. Read more about exporting.

The Layer List

In the Layer List, you’ll find all the Pages, Artboards and layers in your document. You can reorder and rename all of these from here.

How to Hide and Lock Layers

To hide a layer, hover over its name in the Layer List and click the eye icon that appears. If there’s an eye icon next to a layer before you hover it, the layer is already hidden. You can also use + + G to toggle hiding and showing layers.

To lock a layer, hold , hover over a layer and click the padlock icon that appears. Click the padlock to unlock it. Or use + + L to toggle a layer’s lock on and off. When you lock a layer, you won’t be able to edit or move it.

How to Use Pages

You can use as many Pages as you like in your Sketch document. They’re handy for organising your work, as well improving Sketch’s performance with complex documents.

To create a new Page in Sketch, click on the Arrow at the top of the Layer List, then click the add button and give your new Page a name.

Click on the Page you want in the Layer List to navigate to it, or press Fn + or Fn + to jump between them.

You can also collapse your list of Pages and use a drop down menu to navigate between them instead.

You can drag Pages to change their order, or Control-Click on a Page to duplicate or delete it.

Once you’ve created pages, you can drag Artboards or layers within the Layer List from one Page to another in the Pages panel.

How to Use Artboards

Artboards are completely optional, but handy for creating fixed frames on the canvas to create your work in. They’re especially useful if you’re designing for a specific device or screen size.

To create an Artboard, choose Insert > Artboard from the Toolbar or menu bar, or press A. You can either click and drag on the canvas to create a custom size Artboard, or choose a preset from the Inspector.

To save a custom size Artboard as a preset, click the Add button at the bottom on the Inspector and give it a name.

After you create an Artboard, you can press + D to duplicate it.

How to Move Artboards

To move an Artboard, you’ll need to select it. If it doesn’t have any layers inside it, you can click anywhere on it. If it does, you’ll need to click its title on the Canvas, or select it in the Layer List. You can then drag it around the canvas, use the arrow keys to move it, or change its X and Y values in the inspector.

How to Resize Artboards

To resize an Artboard, select it and then click and drag on the selection handles that appear around it. You can also edit its dimensions in the inspector.

You can also set an Artboard to resize its contents at the same time by selecting Adjust contents on resize in the inspector. You’ll need to make sure you’ve set up resizing contraints for the layers within it first, though.

Finally, you can set your Artboards to automatically resize to fit their contents by selecting Fit in the inspector.

How to Delete Artboards

To delete an Artboard, select it and press backspace on your keyboard. Doing this will also delete any layers within it. If you want to keep an Artboard’s contents but delete the Artboard itself, select it and choose Ungroup from the Toolbar, or press + + G.

How to Filter the Layer List

If you have a document with lots of layers, you can use the filter icon at the bottom of the Layer List to find a specific layer type. You can also use the search bar to find a layer by name.

The Components Panel

The Components Panel is a quick and easy way to search, find and manage all the Symbols, Layer Styles and Text Styles in your document and any Libraries you have enabled.

How to Access the Components Panel

To access the Components Panel click on Components at the top of the Layer List (you can also use Ctrl+1 and Ctrl+2 to toggle between the Components Panel and Layer list, respectively). You’ll have the option to view “All” components or just components belonging to your document or a particular Library.

The three icons below this list allow you to view Symbols, Text Styles and Layer Styles.

How to Filter the Components Panel

You can use the search bar at the bottom of the panel to filter your selection. Clicking on any Component reveals a large preview at the bottom of the panel, so it’s easy to distinguish between Symbols or styles with minor differences.

When you’ve found the Symbol or style you want to use, you can drag and drop that component straight onto your Canvas to start working with it.

Organizing Components

The Components Panel makes it easy to organize your Libraries. Double click on any Component to rename it, and if you want to organize them into folders — simply drag one on top of the other.

Last modified on Oct 18, 2019

Was this article useful?

Yes
No

We’re really sorry about that.
Please let us know what you were looking for:

If you need more help or you’d like to report a bug with this content, please contact support.

Thanks for your feedback.
An error occurred, please try again later.

Start working faster today

Available exclusively on the Mac for just $99.