Real-time Collaboration (beta)

With real-time collaboration (beta), you can work together on the same document, see everyone’s changes instantly, and never have to wonder about whether you’re editing the right version of a document again.

Real-time collaboration is available in beta as part of version 71 of the Mac app. We’re slowly rolling out this update to everyone so if you haven’t been prompted to download it just yet, don’t worry — it will be available for you soon!

Real-time collaboration (beta) requirements

To edit documents together using the real-time collaboration beta, you’ll need:

  • A Teams subscription. To find out if you have a Teams subscription choose Sketch > Preferences in the Mac app and click on the account tab. The type of account you have is listed next to your avatar.
A screenshot showing the Account tab in the Preference Window in the Mac app.
  • A shared document in your team’s workspace. You can save a new document to Cloud, move existing documents from a personal to a shared workspace in the browser, or use the Mac app’s Documents window. To do this, choose Window > Documents (or press + + O), then drag and drop your document into the relevant Project in the sidebar. Please remember to create a backup of your documents first!
  • A compatible version of the Mac app. Only version 71 or later are compatible. Once you’ve saved your document, only people with a compatible version of the Mac app will be able to open and edit it. Remember that documents you save with 71 are not backwards compatible.

How to get started with real-time collaboration

In order to use real-time collaboration with a document, you’ll first need to open it in a compatible version of the Mac app (71 or later) and save it, making sure it’s in your Cloud Workspace.

Saving a new document for the first time

To collaborate on a new document, first you’ll need to save it to your team’s workspace. Choose File > Save or hit + S, select the Sketch Cloud tab in the save sheet and select your shared Workspace.

Alternatively, you can click the Collaboration toolbar item Collaboration and choose Save to Cloud in the popover menu that appears.

Saving an existing document to make it compatible with real-time collaboration

Once you’ve moved an existing document to your shared Workspace, you’ll need to open it and save it again in a compatible version of the Mac app (v71 or later). The Mac app will prompt you to do this when you open the document for the first time. Once you’ve saved your document, only people with a compatible version of the Mac app (v71 or later) will be able to open and edit it. Once you’ve opened a document in version 71, you will be able to open it in older versions of the Mac app but you’ll only be able to save locally or upload it as a new document in your Workspace.

Note: Embed any fonts you use when sharing your file to make sure everyone can edit all the text in your document.

Inviting people to collaborate

When you save your file to a Workspace, everyone in that Workspace will be able to see the document, and anyone who is a Contributor can open it in the Mac app to start collaborating. You can invite people from outside your Cloud Workspace to collaborate on your document as long as they have a compatible version of the Mac app (71 or later), a valid Sketch license and a Cloud account.

How to manage share settings

To change your document’s share settings, click on Collaboration toolbar item Collaboration and choose Share Document…. Find out more about managing these settings.

How to invite people from outside your team

You can invite people from outside of your Team to collaborate with you on a document as long as they have a valid license, a compatible version of the Mac app and a Cloud account.

From Cloud: If you’re viewing a document in your web browser, open it and click the cog icon in the top-right of the screen and choose Document Settings…, then select Sharing and Permissions. Here you can change the link settings so that anyone with the document link can view or inspect and download the document. Alternatively, you can also invite people to your document via email. To invite someone to edit with you real-time you’ll need to set their permissions to Edit. Learn more about managing share settings.

From the Mac app: Click Dots Cloud in the toolbar and choose Share Document…. The document will open in Cloud, where you’ll see the window described above.

A screenshot showing how to share a document from the Mac app.

Opening a document to collaborate

From the Mac app To open a document from the Mac app, choose File > Open Cloud Document… in the menu bar and open the document from the Documents window.

From the web app If it’s the first time you’re opening the document, make sure you are signed into the web app, then use the link you received to access it. Click Open In Sketch in the bottom-right corner of the window.

When you are opening a document from the Document’s overview (web app) or the Document’s window (Mac app), you’ll see the name of the last person who worked in the document under the document’s thumbnail. If someone is currently working on a document, you’ll see their name next to the word Editing. Open the Activity Feed in any document to see its live status.

A screenshot showing the Shared with me tab in the Document Window in the Mac app and whos editing a document.

Working in real-time

The collaboration menu and cursors

In the toolbar, you’ll see up to three avatars of active collaborators. The colored circle around the avatar matches the color of their cursor on the Canvas. Click Dots Cloud in the toolbar above Collaboration to open the menu.

The menu shows a list of all the Contributors who are working in the document, as well as some useful sharing options. You can also see if someone is active (you’ll see a colored ring around their avatar) or away.

A picture showing the collab menu.

Tip: To hide or show the cursors or names of your collaborators, click your own avatar in the toolbar and select Show Collaborators Cursors/Names to hide your collaborator’s cursors and/or names.

You can also see who is currently collaborating on a document when you’re viewing your Team’s shared workspace in the browser. Open the Activity Feed in any document to see its live status.

Note: If you don’t see Collaboration Collaboration in the toolbar, choose View > Customize Toolbar… then drag it into your toolbar from the sheet that appears.

Editing in real-time

When you collaborate real-time in the Mac app, you’ll be able to see the layer a collaborator is working on and where they are in the Canvas. However, you’ll only be able to see their edits once they complete an action. This means you won’t see edits happen pixel-by-pixel, — instead, you’ll see the result of an action.

Note: To keep the work of all collaborators safe, you’ll only be able to undo your own actions.

Working on the same object

Two or more collaborators can edit the same layer at the same time, but this might cause issues if you undo and redo edits. While undo and redo commands only affect your own edits, they could override someone else’s changes if they perform an edit immediately after you. To prevent this, it’s best to avoid editing the same layer at the same time by watching out for everyone else’s cursors and selections.

Follow mode

To follow someone else as they collaborate with you in a document, open the Collaborate menu and click on their avatar. In follow mode, your Canvas will match the view of the person you’re following. We’ll also display their name at the top of the Canvas and outline it using their cursor color. The Mac app will also notify the person that you are currently following them.

If you can’t follow someone, it might be because:

  • They are inactive
  • They leave a document
  • Their settings mean you can’t follow them
  • They are following you or someone else

If you follow someone and they become inactive, you’ll stop following them. If they leave the document, you’ll see their Canvas view, but not their cursor.

To stop following someone, zoom or click anywhere on the Canvas.

Setting your following preferences

You can choose whether or not people can follow you by clicking on your Avatar in the Collaboration menu… and clicking Allow Users to Follow you. Alternatively, head to View > Canvas > Allow Users to Follow you.

How to save documents during collaboration

When you collaborate, every change you make syncs to everyone else in real-time, and anyone else who opens the document while you’re working will get all the latest updates automatically.

Even though all edits sync automatically, you can save a snapshot of the latest edits as a new update at any time — you can also see who created that update. These updates appear in the document’s timeline in the web app. You can Star an update, to mark it as important, make it visible to viewers or share its updates, if it’s a Library.

While we recommend making your edits to a shared document from your Workspace, you can download any shared document and work on it locally, then upload the entire document again. When working offline, the Mac app will sync all your changes back to the document in your Workspace when you reconnect.

Saving when you close the Mac app

There is no need to manually save your document before you close a document or quit the Mac app. When you complete either of these actions, the app combines all your latest updates into a new update of the file, and saves it to Cloud automatically.

Saving a new update

Manually saving your file by hitting + S or choosing File > Save will also create a new update of the document in Cloud. Viewers in your Team will be able to view, comment on and inspect these versions for handoff. Find out more about updates.

Getting feedback on collaborative documents

Once you’ve saved your file to Cloud, Viewers and Collaborators can view the document in their browser, add comments, and inspect it for handoff. Find out more about what you can do in Cloud.

Read our Get started with real-time collaboration guide for a run through the steps to get started.

Real-time collaboration is available in beta as part of version 71 of the Mac app. We’re slowly rolling out this update to everyone so if you haven’t been prompted to download it just yet, don’t worry — it will be available for you soon!

Last updated on 17 Mar 2021

Was this article useful?

We’re really sorry about that.
Please let us know what you were looking for:

If you need more help or you’d like to report a bug with this content, please contact support.

Thanks for your feedback.
An error occurred, please try again later.