Skip Navigation

Adding Hotspots

Hotspots Insert Hotspot offer more control than Links and are useful if you want to create a clickable area that’s larger than a single Layer.

To add a Hotspot Insert Hotspot, make sure you have nothing selected on the Canvas, then choose Insert > Interaction Insert Hotspot (or press I) and click-and–drag to draw your Hotspot area. After that, click on the Artboard you want your Hotspot to Link to.

How to add a prototyping Hotspot in the Mac app (v92 August 2022)

You can edit your Hotspot’s animation and target Artboard, in the Inspector, just like you can with Links.

Select any Link and click the “Create separate Hotspot layer” icon Add Link to Artboard tool in the INTERACTION section of the PROTOTYPE tab of the Inspector to turn it into a Hotspot.

How to fix the Position of a Hotspot

Select your Hotspot and then choose the Fix position when scrolling checkbox in the PROTOTYPE tab of the Inspector to fix its position on the canvas even as the rest of your Layers scroll.

An image showing the control to fix a prototyping Hotspots position while scrolling

How to fix a prototyping Hotspots position while scrolling using the PROTOTYPE tab in the Mac app (v91 August 2022)

How to use Hotspots with Symbols

If you include a Hotspot as part of a Symbol, you can reuse that same Symbol but individually override its Hotspot’s target. You can also override the Hotspot’s target to “None” if you don’t want it to Link to another Artboard.

  • To hide or show Hotspots head to View > Show Hotspots or press H.
  • To show all Links and Hotspots choose View > Prototype > Show all or press F. You can also choose to just show those Hotspots related to your selected layers by heading to View > Prototype > Show with selection .
  • To only see Links and Hotspots when you’ve selected a specific Artboard, layer or group they’re related to, choose View > Prototype > Show with selection or press F. You can also change their color under the Canvas section in Preferences.

From Version 90 onwards you can view Hotspots and interactions by switching to the PROTOTYPE tab in the Inspector.

Last updated on 07 Sep 2022

Was this article useful?

Thanks for your feedback.
An error occurred, please try again later.