Skip Navigation

Shortcuts

Keyboard shortcuts are the fastest way to speed up your workflow. Many of them are depend on what you’ve selected and what you’re doing, but you’ll find the full list of Sketch keyboard shortcuts below.

General shortcuts

C Copy
X Cut
V Paste
V Paste over selection
 Space  drag Pan Canvas
N New page
fn Previous page
fn Next page
+ Zoom in
- Zoom out
R Show/hide rulers
P Show/hide pixels
X Show/hide pixel grid
G Show/hide grid
G Access grid settings
L Show/hide layout grid
L Access layout settings
E Show/hide slices
F Show all Hotspots and Links
F Show Hotspots and Links for selected Artboards, layers or groups.
12 Switch between Canvas and Components View
F Filter in Layer List/Components View
1234 Switch between Component types in the Compenents View and Insert Window
K Run custom plugin
Z Undo
Z Redo
N New document
O Open Workspace window
O Open local document
W Close window
S Save document
S Duplicate
S Save As…
P Page setup
, Open Preferences
H Hide the Mac app
Q Quit the Mac app
? Open the Help menu
P Open the Prototyping Preview window
, Open the Document Settings window

Note: When Auto Save is disabled in Preferences, the Duplicate menu item is replaced by Save As…

Inserting Layers

You can use the following shortcuts instead of choosing them in the Insert menu.

R Rectangle Rectangle tool
O Oval Oval
L Line Line
U Rounded rectangle Rounded
V Vector tool Vector tool
P Pencil tool Pencil
T Text tool Insert Text
A Artboard tool Artboard
S Slice tool Create a slice
H Hotspot tool Insert Hotspot
C Open the Insert Window
Enter Insert selected Component onto Canvas from Insert Window
Enter Go to selected Symbol’s Source from Components View
drag Draw a new shape from center
drag Lock the ratio of shape as you draw it
 Space  drag Move a new layer before you place it

Selecting Layers

Click Select a layer
Click-and-drag Select multiple layers
drag Select layers completely within your selection area
click Select a layer within a group
Tab Select next layer in group
Tab Select previous layer in group
Enter Select frontmost child of group, or edit layer
Escape Selects parent group
click Select an obscured layer
A Select all layers, except hidden and locked layers
A Select all layers, including hidden and locked layers.
A Select all Artboards
click Add layer to/remove layer from your selection
click Add layer from a group to your selection
click Add layer to selection/deselect a layer
click Select a range of layers
double-click Maintain your selection while adding layers within groups
fn Jump to next Artboard
fn Jump to previous Artboard
J Reveal selection in Layer List
Tab orTab Navigate layers in the Canvas
Escape Clear selection

Moving and Resizing Layers

As you move or resize layers, you’ll see smart guides and measurements automatically.

hover Display distance between other layers
L Locks/unlocks layer proportions when resizing
D Duplicate
drag Duplicate
drag Move layer along X or Y axis
drag Move layer and ignore smart guides
drag Move an obscured layer
Arrow keys Nudge layer any direction by 1 px*
Arrow keys Nudge layer any direction by 10 px*
K Scale layer
and resize Resize layer from center
and resize Preserve the layer’s ratio
or Expand by 1 px
or Contract by 1 px
or Expand by 10 px
or Contract by 10 px
hover Show distance to baseline/cap height on text layers

*You change this value in Preferences.

Editing Layers

When you’ve selected a layer, you can use the following shortcuts:

Enter Edit layer
Esc Finish editing
Esc Deselect layer selection in groups
Tab Edit the X position in the Inspector
Delete layer
C Copy style
V Paste style
S Sync shared style
S Reset shared style
W Add link to Artboard
F Toggle fill
B Toggle border
C Pick color
0 to 9 Edit layer opacity
T Transform shape
R Rotate layer
M Use the layer as a mask
Escape Return to instance
U Union multiple layers boolean union
S Subtract multiple layers boolean substract
I Intersect multiple layers boolean intersect
X Difference multiple layers Difference (blend mode)

Vector Editing

O Open/close path
Tab Select the next point
Show all handle control points
1 Straight point type Straight
2 Mirrored point type Mirrored
3 Disconnected point type Disconnected
4 Asymmetric point type Asymmetric
Double-click vector point Toggle point between Straight and Mirrored
drag vector point Move point along X or Y axis
drag handle control point Convert your selected point to a Disconnected type
click (when inserting points) Place new point at a 45º angle
click path segment Place new point between existing points
click path segment Curve the path between existing points

Text Editing

V Paste as rich text
T Change typeface
B Bold
I Italic
U Underline Underline text
+ Increase font size
- Decrease font size
L Increase character spacing
T Decrease character spacing
{ Align left Left Alignment
| Align center Center Alignment
} Align right Right Alignment
 Space  Emoji & symbols
O Convert to outlines
Return Insert a line break

Organizing Layers

Use these shortcuts to organize your layers.

G Group Group
G Ungroup Ungroup
R Rename layer
Click-and-drag layer Adjust layer hierarchy
] Bring forward Forward
] Bring to front
[ Send backward Backward
[ Send to back
Move up (out of group/Artboard)
H Align horizontally Distribute layers horizontally
V Align vertically Distribute layers vertically
H Align horizontally in an Artboard Distribute layers horizontally
V Align vertically in an Artboard Distribute layers horizontally
Align layer to the left
Align layer to the right
Align layer to the top
Align layer to the bottom
Align layer to the left within an Artboard
Align layer to the right within an Artboard
Align layer to the top within an Artboard
Align layer to the bottom within an Artboard
click Align buttons Align layer to Artboard
H Hide/show layer Hide Show
L Lock/unlock layer Lock/Unlock rulers

Exporting Layers

E Export
E Export selected layer(s)
Drag a layer/thumbnail to Desktop Export asset
Drag a layer/thumbnail to Canvas Insert flattened duplicate
/ in layer name Includes folder in export

Symbols

Y Create Symbol Create Symbol
Y Detach from Symbol Detach
Y Detach all contents from Symbol

Zoom and Focus

0 Zoom to 100%
1 Zoom to all elements on Canvas
2 Zoom to selected layer(s)
3 Center selected layer(s) in the Canvas
Z drag Zoom to area
Z click Zoom in
Z click Zoom out
~ (or § on some keyboards) Temporarily zoom out to 100%
F Toggle full screen
1 Show/hide Layer List
2 Show/hide Inspector
. Enter presentation mode
T Show/hide toolbar

Text Fields

These shortcuts apply when you’re editing a numerical field in the Inspector:

Tab Focus Inspector
Tab Select next field
Tab Select previous field
Enter Confirm change
Escape Clear change
Increase value by 1
Decrease value by 1
Increase value by 10
Decrease value by 10
Increase value by 0.1
Decrease value by 0.1
click and drag label Adjust value in increments of 10
click and drag label Adjust value in increments of 0.1

Resizing Shortcuts

When you’re adjusting the height or width of a layer, the following characters give you more control over the starting position of the resize.

L Scale from the left (default)
R Scale from the right
T Scale from the top (default)
B Scale from the bottom
C / M Scale from the center / middle

How to Use Math Operators

You use these math operators in all numerical inputs of the Inspector.

+ Add
- Subtract
* Multiply
/ Divide
% Resize layer to a percentage of its parent group or Artboard

How to Set Individual Radius Values

When you select a rectangle, you can specify a different value in the radius field for each corner in the Inspector by using ; as a spacer (e.g. 40;0;40;0).

Export Fields Shorthand

In the Scale field of the Make Exportable panel in the inspector, the following characters can customize your export sizes.

X Scale multiplier. Eg, 2x will export at twice the size
H Export your layer at a specific height. Eg, 512h
W Export your layer at a specific width. Eg, 512w

Miscellaneous

These shortcuts are available for specific tools or when you’re performing specific actions.

on startup Launch the Mac app with all plugins disabled
D Refresh Data
R Run the last plugin you used again
drag selection handle Rotate layer
drag when rotating Snap rotation to 15º increments
0 to 9 With a gradient stop selected, position it between 0% and 100%
= Position selected gradient stop directly between two existing stops
C Brings up the eyedropper Eyedropper tool to set that layer’s fill color

Custom Shortcuts

You can create custom shortcuts for Sketch by opening System Preferences, heading to Keyboard › Shortcuts › App Shortcuts and clicking the add button. In the pop-up menu, select Sketch under the Application drop-down menu and set up your custom shortcut.

Web app Shortcuts

These shortcuts are available when viewing Sketch documents in the web app.

0 Zoom to 100%
1 Fit to Screen
+ Zoom in (US Keyboards)
= Zoom in (Non-US Keyboards)
- Zoom out
click Show Layer Menu
or Navigate Artboards
/ Show Keyboard Shortcuts Sheet
Esc Hide Keyboard Shortcuts Sheet
Last updated on 02 Nov 2021

Was this article useful?

We’re really sorry about that.
Please let us know what you were looking for:

If you need more help or you’d like to report a bug with this content, please contact support.

Thanks for your feedback.
An error occurred, please try again later.