Other

Using Templates

Templates can be opened as a new document with pre-populated layers. Sketch comes with several useful sample templates, including the iOS App Icon and Material Design templates.

You’ll see a grid view of templates in the Documents window. You can bring this up at any time by choosing Window › Documents. You can also get a list of templates by choosing File › New From Template….

A screenshot showing the templates browser in the documents window in Sketch

Creating Templates

To save a document you’ve created as a template, choose File › Save as Template….

You can also manually save and organize Templates into folders, as well as give them custom preview images in the Finder. You’ll find them in: ~/Library/Application Support/com.bohemiancoding.sketch3/Templates.

How to Create Custom Template Previews

To give your templates a custom preview, add a PNG image with the same filename as your template to its location in the Finder. For pixel-perfect previews, images should be 188 × 188 px for Retina displays, or 94 × 94 px otherwise.

Last modified on Oct 23, 2019

Was this article useful?

Yes
No

We’re really sorry about that.
Please let us know what you were looking for:

If you need more help or you’d like to report a bug with this content, please contact support.

Thanks for your feedback.
An error occurred, please try again later.

Start working faster today

Available exclusively on the Mac for just $99.